Bitsend Core Wallet version 0.14.2.0

Dear Bitsend (BSD) user and supporter,
Bitsend Core Wallet version 0.14.2.0 has now been released which includes a very important security fix for a DoS vulnerability, CVE-2018-17144!

We would highly recommend to upgrade as soon as possible. The release is available now at: https://github.com/LIMXTEC/BitSend/releases/tag/0.14.2.0.0

Your Bitsend Team

No Comments

Sorry, the comment form is closed at this time.