[Guide] Running Bitsend Wallet in Ubuntu 17.04 Zesty Zapus

  • 1 Replies
  • 522 Views
*

bb2ebb

  • Newbie
  • *
  • 10
  • +0/-0
    • View Profile
using command lsb_release -a You can see that this linux is really ubuntu version 17.04 called zesty zapus



STEP-BY-STEP RUNNING BITSEND WALLET IN UBUNTU 17.0 ZESTY ZAPUS
  • I am using bitsend wallet version 1.2.7.1.  I download it using the command
    wget https://github.com/LIMXTEC/BitSend/releases/download/BSD1271/BitSend-linux64.zip

    don't forget to unzip, you can using command unzip BitSend-linux64.zip

  • Install the main of dependancies.  this dependancies is recommended from bitsend developer
    add-apt-repository ppa:bitcoin/bitcoin
    sudo apt-get update
    sudo apt-get install libdb4.8-dev libdb4.8++-dev build-essential libtool autotools-dev autoconf pkg-config sudo libssl-dev libboost-all-dev git npm nodejs nodejs-legacy libminiupnpc-dev redis-server


  • try running bitsend. still error with missing dependancy
    Quote
    ./bitsend-qt: error while loading shared libraries: libboost_system.so.1.58.0: cannot open shared object file: No such file or directory
    well, we had been installing dependancy but still show error


  • because the standard version of libboost in repository ubuntu 17.0 (Zesty Zapus) is version 1.61, 1.62 and 1.63, so libboost 1.58 is no exist in there.

    we shall installing libboost 1.58 manually. follow this command
    sudo apt-get install g++ python-dev autotools-dev libicu-dev libbz2-dev
    wget -O boost_1_58_0.tar.gz https://sourceforge.net/projects/boost/files/boost/1.58.0/boost_1_58_0.tar.gz/download
    tar -xvzf boost_1_58_0.tar.gz
    cd boost_1_58_0/

    ./bootstrap.sh --prefix=/usr/local
    user_configFile=`find $PWD -name user-config.jam`
    echo "using mpi ;" >> $user_configFile
    n=`cat /proc/cpuinfo | grep "cpu cores" | uniq | awk '{print $NF}'`
    sudo ./b2 --with=all -j $n install
    sudo sh -c 'echo "/usr/local/lib" >> /etc/ld.so.conf.d/local.conf'
    sudo ldconfig


  • Now, running bitsend and appear error about libqrencode 3
    Quote
    ./bitsend-qt: error while loading shared libraries: libqrencode.so.3: cannot open shared object file: No such file or directory


    for fixing it, use the command in below :
    apt-get install libqrencode3 libqrencode-dev

  • Now, running bitsend and appear error about libprotobuf 9
    Quote
    ./bitsend-qt: error while loading shared libraries: libprotobuf.so.9: cannot open shared object file: No such file or directory


    for fixing it, use the command in below :
    wget https://github.com/google/protobuf/releases/download/v2.6.0/protobuf-2.6.0.tar.gz
    tar -xvzf protobuf-2.6.0.tar.gz
    cd protobuf-2.6.0/
    sudo ./configure
    sudo make
    sudo make check
    sudo make install
    sudo ldconfig


  • After all of the above, you can running your bitsend-qt properly





VIDEO TUTORIAL
https://www.youtube.com/watch?v=5C35Ck7-XUE

*

Neelaksh123

  • Regular
  • Full Member
  • *
  • 117
  • +0/-0
  • Bitsend Supporter
    • View Profile

 

Sitemap 1 2 3 4 5 6 7 8 9 10 11 12 13